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Spreadsheet pivot table example download

There are sample Excel files on my Contextures site, with data you can use for testing, or demos. The original sample file has sales data for a fictional office supply company. I've added more files recently, so see if they’ll be helpful to you too. New Sample Data Files Here’s a list of the new sample data files, and there are details below. Insurance
Policies - 10 columns, 500 rows Food Sales - 8 columns, 244 rows Hockey Players - 15 columns, 96 rows Insurance Policies This sample has fictional commercial property insurance policy data. You can see a small section of There are 10 columns of data, with no calculations. There are 500 rows of data in the insurance policy table. Food Sales This
sample has fictional food sales data. There are 8 columns of data, including 1 column with a calculation. There are 244 rows of data in the food sales table. Hockey Data This sample has data from the 2018 Olympic Hockey teams, from Canada and the USA. There are 15 columns of data, including 4 columns with calculations. There are 96 rows of data
in the hockey player table. I created pivot tables from this data, and wrote about it in a blog post on hockey player data analysis. You can see some of my pivot tables below. Hockey Player Pivot Tables The first table shows player counts, for each position, plus age, height and weight. For each value, there are 3 different summary functions - Average,
Minimum, and Maximum. In the country subtotal row, conditional formatting highlights the higher amounts in red, and lower amounts in green. A Slicer at the top left lets you see the data for Men or Women. And this pivot chart shows the age ranges for the Men’s and Women'’s players, from both countries. The men have a substantially longer
career, from what this shows. Video: Filter All Pivot Charts If you have several pivot charts on an Excel dashboard, and space is limited, here’s a way to change all pivot charts with a single filter cell. There are NO macros, just Slicers that are stored on a different sheet. There are details in the Change All Pivot Charts with Single Cell Filter blog post.
Get the Sample Data Files To get the Excel sample data files, go to the Sample Data page on my Contextures site. If you’d like to see the hockey data file with the completed pivot tables, click this link to get my player data analysis workbook. All of the zipped files are in xlsx format, and do not contain macros.
Pivot Table is a great tool for summarizing and analyzing data in Excel. We can use a Pivot Table to perform calculations on our data based on certain criteria. For example - Sales per Store, Sales per Year, Average Discount per Region, and many more... Here are some of the advantages of using Pivot Tables: There is no
need to use formulas in order to perform calculations. We can perform complex calculations in a quick and simple way. The summarized data is dynamic and can easily be applied to different sets of data Click to download our absolutely FREE Pivot Table Exercise Creating a Pivot Table To create a new Pivot Table, we first need to select the data
range which we would like to analyze, then click on one of the desired cells in our data range, then click Insert tab, then Pivot Table. Let’s assume we want to analyze a database of cars sold by a car vendor: To create a new Pivot Table: We will click on one of the cells in the data range. We will go to the Insert tab and click on Pivot Table: Next, we will
confirm that the selected range is indeed the right range. Last, we will select “New Worksheet” to create the Pivot Table in a new worksheet, or “Exisiting Worksheet”, to place it in an existing worksheet. After we decided to create a Pivot Table, we can see all the column headers - these are the fields from our database which we can work with: To
start creating our Pivot Table, we can drag the different fields to the following areas: Rows - Here we will choose the field/s which we would like to base our Pivot Table rows upon. Columns - Here we will choose the field/s which we would like to base our Pivot Table columns upon. Filters - Here we will choose the field/s by which we would like to
filter our data in the Pivot Table. i.e.- we would choose “Year” to filter by a specific year. Values - Here we will choose the field we want Excel to calculate and our desired calculation. Creating a basic Pivot Table - Example One of the most basic examples of using a Pivot Table is summing values of a specific field based on a criteria that appears in a
different field. In order to do so, we will drag the field which we would like to analyze into the “Rows” area or “Columns” if we would like to present the analysis in columns. We will the drag the field we want to sum into the “Values” area: Changing the way Values are calculated We will notice that most times, the basic calculation we will get when
dragging a field to the “Values” area will be “Sum”. We can change the calculation by clicking the field after we dragged it into the “Values” area, then “Value Field Settings...”, which will open a menu where we can choose to sum, count, average and many more calculations: Segmentation to Columns and Rows We can segment the data using rows
and columns simultaneously by dragging fields to the “Rows” and “Columns” areas: Performing multiple calculations on the same field We can perform a number of different calculations on the same field by dragging the field several times to the “Values” area and changing the type of calculation in each of the columns: Segmentation of more than
one field In the Pivot Table, we can segment based on more than one field by dragging several fields into the “Rows” area: Designing a Pivot Table Changing the Pivot Table design to a classic table design In order to give the Pivot Table a “classic” look, where each field is presented in a different column, we will click the Pivot table, click on “design”
and perform the following steps: Click on Report Layout Click on “Show in Tabular Form” to show the table in a classic format Click on “Repeat All Items Labels” to show all item labels. We can click on “Do Not Show Subtotals” to hide the subtotals in the newly created table. This is the process and final result: Formatting a Pivot Table field We can
quickly select the way we wish to format a certain value field, by right-clicking the field and then clicking on “Format Cells”, or directly on “Number Format”, if we wish to format the values as number and add 1000 separator (4,524,254 instead of 4524254): Designing missing values and errors We can control the way missing values (empty cells) or
errors are presented in the Pivot Table by right-clicking one of the cells and clicking on “Pivot Table Options”, then ticking “For error values shows” or “For empty cells show” (as shown in the following example) Filtering a Pivot Table Filtering existing fields in a Pivot Table We can filter data shown in the Pivot Table rows simply by clicking the
corresponding button in the desired field. For example, to filter the “Gear” field, we simply have to click the button next to the field name: Filtering values in a Pivot Table What if we wanted to filter the values in our Pivot Table? To do so, we can start our filtering by clicking the filter button in one of the fields, then click on “Value Filters”, following
which we will be able to see the various value filtering options. Here’s an example of how to filter values greater than 40,000: Adding an external filter to a Pivot Table If we want to filter based on a field that is not currently in the Pivot Table, we could drag that field into the “Filters” area: Please note - we can add more than one field to the “Filters”
area. Sorting values in a Pivot Table If we want to sort our fields, we just have to right-click on the desired field and click on “Sort”: Updating and refreshing the Pivot Table data After updating the source data, we have to refresh the Pivot Table in order for the new data to be reflected in the Pivot Table. We can do that by right-clicking the table and
clicking on “Refresh” or by Refresh/Refresh all in the “Data” group Adding new data at the end of the data range If we want to add new data to our Pivot Table that will be added at the end of the previously used data range, we need to update the source data’s range by clicking on “Change Data Source” in the “Data” group: Another way of dealing
with this issue is by adding the new data in the middle of the previously used data range and then refreshing. Automatically update Data Source Range when adding new rows by using Tables Another way to save time if we are planning to update the data source range often is changing the data source range to a table by clicking in “Table” in the
“Insert” tab or by clicking CTRL+T Now we can create/update the Pivot Table that will use the table as the source data, and when the table will be updated- the Pivot Table’s source data range will be updated as well. Here’s how our Data Source looks like: Show Values As We can present the calculated values in the “Values” area in different ways,
i.e. a percentage of total, by clicking the desired value in the “Values” area, then clicking on “Value Field Settings” and then on “Show Value As”: Presenting a breakdown of a value in a Pivot Table Whenever we like, we can present all the items that are calculated in a certain cell in the Pivot Table by double-clicking that cell. This will result in a new
sheet opening: Grouping Data We can group data presented in the Pivot Table’s rows and columns with “Group” and reverse it with “Ungroup” by right-clicking one of the cells: Date data will usually be grouped automatically to months/years We can also group numerical data (i.e 1-100, 101-200, etc.) Creating Pivot Charts We can add charts to
existing Pivot Tables or create new charts based on a new Pivot Table. Existing Pivot Table - We will click on the “Analyze” tab and then on “Pivot Chart” in the “Tools” group (we have to select a cell in the Pivot Table before doing this) Creating a new Pivot Table - “Insert” tab -> “Pivot Chart” in the “Charts” group (we have to select the desired
source data before doing this) When we click on the Pivot Chart, the names of the categories will look like this: Like any other chart, we can control the axis’ directions and the chart type by clicking on the “Design” tab. We can, for example, replace the X and Y axis by “Switch Row/Column” in the “Design tab”. We can also change the Chart type: It is
important to note that Pivot Charts behave exactly as Pivot Tables, so each functionality that can be used in Pivot Tables, can also be used in Pivot Charts. Adding Slicers / Timelines to a Pivot Table Adding Slicers to a Pivot Table We can add Slicers to our Pivot Table / Chart, which will enable visually filtering the field, by clicking on the “Analyze” tab
and then on “Insert Slicer”. Here’s how it looks: We can have multiple slicers to our Pivot Table, which will work simultaneously: We can select several values in the Slicer by using CTRL/ SHIFT. To cancel the filtering of a Slicer, we will click on this button at the top of the Slicer: Adding a Timeline to a Pivot Table For date fields, we can add a
Timeline by clicking on the “Analyze” tab and then on “Insert Timeline”: Pivot Table Calculated Fields We can perform calculations within the Pivot Table itself, Instead of creating calculation columns in the source data. For that, we can use a “Calculated Field”. A Calculated Field is calculated based on the sum of a certain field. We will add a
Calculated field by clicking on: Analyze tab -> Fields, Items & Sets -> Insert Calculated Fields: We will name each Calculated Field and write the desired formula for it (you can insert the desired field by double-clicking it). Here’s an example of calculating the Sales amount after a 2% commission: Practice Pivot Table Click here to download our FREE
Excel Pivot Table exercise, in which you will be able to practice and learn how to create Pivot Tables, design them, update their data, create Pivot Charts, adding Slicers and many more Pivot Table tips and tricks! Home > Data > Sample > Sample Data Get this Microsoft Excel sample data for practice and training. Quickly download the dummy data
for office supply orders, then use it to while learning how to lookup, sort, filter, create formulas, pivot tables and more Excel skills! The sample data on this page is sales data for an fictional office supply company. Each row in the data represents one sales order. There are 2 ways to get the sample data: The sample data on this page is sales data for an
fictional office supply company. The screenshot below shows a few rows of the data, and all 7 columns in the list.. 2.1) Sample Data Columns (Fields) Each row in the Excel dummy data shows the following seven fields: Order Date: first column shows date that the order was placed Region: geographical area where the sale was made - East, West or
Central Rep: sales representative's last name (family name) Item: name of the stationery item sold, such as binder, pencil, or desk. Units: number of units sold UnitCost: cost of one unit Total: total cost of the order Instead of downloading the Office Supply data, you can copy and paste the sales data into your Excel file, from the list shown below. Tip:
For step-by-step notes how how to copy and paste the list, go to the Copy Paste Steps section, below the list OrderDate Region Rep Item Units UnitCost Total 1/6/2024 East Jones Pencil 95 1.99 189.05 1/23/2024 Central Kivell Binder 50 19.99 999.50 2/9/2024 Central Jardine Pencil 36 4.99 179.64 2/26/2024 Central Gill Pen 27 19.99 539.73 3/15/2024
West Sorvino Pencil 56 2.99 167.44 4/1/2024 East Jones Binder 60 4.99 299.40 4/18/2024 Central Andrews Pencil 75 1.99 149.25 5/5/2024 Central Jardine Pencil 90 4.99 449.10 5/22/2024 West Thompson Pencil 32 1.99 63.68 6/8/2024 East Jones Binder 60 8.99 539.40 6/25/2024 Central Morgan Pencil 90 4.99 449.10 7/12/2024 East Howard Binder
29 1.99 57.71 7/29/2024 East Parent Binder 81 19.99 1619.19 8/15/2024 East Jones Pencil 35 4.99 174.65 9/1/2024 Central Smith Desk 2 125.00 250.00 9/18/2024 East Jones Pen Set 16 15.99 255.84 10/5/2024 Central Morgan Binder 28 8.99 251.72 10/22/2024 East Jones Pen 64 8.99 575.36 11/8/2024 East Parent Pen 15 19.99 299.85 11/25/2024
Central Kivell Pen Set 96 4.99 479.04 12/12/2024 Central Smith Pencil 67 1.29 86.43 12/29/2024 East Parent Pen Set 74 15.99 1183.26 1/15/2025 Central Gill Binder 46 8.99 413.54 2/1/2025 Central Smith Binder 87 15.00 1305.00 2/18/2025 East Jones Binder 4 4.99 19.96 3/7/2025 West Sorvino Binder 7 19.99 139.93 3/24/2025 Central Jardine Pen
Set 50 4.99 249.50 4/10/2025 Central Andrews Pencil 66 1.99 131.34 4/27/2025 East Howard Pen 96 4.99 479.04 5/14/2025 Central Gill Pencil 53 1.29 68.37 5/31/2025 Central Gill Binder 80 8.99 719.20 6/17/2025 Central Kivell Desk 5 125.00 625.00 7/4/2025 East Jones Pen Set 62 4.99 309.38 7/21/2025 Central Morgan Pen Set 55 12.49 686.95
8/7/2025 Central Kivell Pen Set 42 23.95 1005.90 8/24/2025 West Sorvino Desk 3 275.00 825.00 9/10/2025 Central Gill Pencil 7 1.29 9.03 9/27/2025 West Sorvino Pen 76 1.99 151.24 10/14/2025 West Thompson Binder 57 19.99 1139.43 10/31/2025 Central Andrews Pencil 14 1.29 18.06 11/17/2025 Central Jardine Binder 11 4.99 54.89 12/4/2025
Central Jardine Binder 94 19.99 1879.06 12/21/2025 Central Andrews Binder 28 4.99 139.72 In this 18-second video, I show the steps to copy the sample data, and paste it into Excel. The written steps are below the video. Here are the quick steps to copy the data from the table above, and paste into your Excel worksheet: First, select a few letters, at
the start of the Order Date heading Next, scroll down to the end of the sample data table On your keyboard, press Shift, and then click at the end of the last number in the Total column, to select all the data Then, on your keyboard, press Ctrl + C to copy the selected data Next, go to Excel, and select the cell where you want to paste the data Right-
click that cell, and click the Paste command Or use the paste shortcut: Ctrl + V 4) Get More Sample Data Files There are many more Excel files with sample data that you can download! Go to any of the pages listed below, and get more data sets for Excel practice. Food Sales - This sample Excel file has food sales data, from a fictional food company.
For details on this data, and to download the zipped Excel file, go to the Food Sales Sample Data page. Athlete Data - These sample Excel files have data for football players, and winter games athletes. For details on this data, and to download the zipped Excel file, go to the Athletes Sample Data page. Hockey Player Data - This sample file has data
from the 2018 Olympic Hockey teams, from Canada and the USA. For details on this data, and to download the sample file, go to the hockey player data analysis page. Insurance Policies: This sample file has commercial insurance policy data for a fictional insurance company. For details on this data, and to download the zipped Excel file, go to the
Insurance Policy Sample Data page. 5) Where To Go Next Check these pages out, to find new ideas for your Excel practice sessions, or for training topics. * Named Excel Tables * VLOOKUP Function Examples ¢« Drop Down Lists ¢ Pivot Tables Intro « Formulas and Functions * Data Entry Tips Get Monthly Excel Tips! Don't miss my monthly Excel
newsletter! You'll get quick tips, article links, and a bit of fun. Add your email, and click Subscribe. Next, when you get my reply, click the Confirm button. I add this step to protect you from spam! 6) Down the Rabbit Hole In this section, you'll find related Excel tips, shortcuts, skills, and details. These things are nice to know, but not essential, so you
can skip this section, and get back to work. Or dive in, for some extra Excel fun and knowledge! --1) Why Use Sample Data in Excel? --2) Tip: Create an Excel Table --3) Create Your Own Test Data 6.1) Why Use Sample Data in Excel? Here are a few of the reasons that people have shared with me, as to why they like using these datasets, with dummy
data for Excel: Quick way to get interesting data for Excel training class exercises No privacy concerns about using real data from your employer or your client's company Useful for testing macros and manual processes - you might discover problems that didn't occur with original test data Handy data to share when helping with Excel forum
questions. Send people to this page, so they can download the sample data, and recreate their problem or error there. It's easier to help with troubleshooting when you both have the same data Easy to prepare class demos for sum and count formulas, lookup functions, pivot tables, summary reports, and other Excel skills training Tip: Check the Key
Excel Skills page, for training topic ideas. 6.2) Tip: Create an Excel Table After you copy the Office Supply Sales sample data from the table above, and paste it into Excel, you can format the data as a named Excel table. This will make it easier to sort and filter the data. Watch this short video to see the steps, and there are written instructions on the
Creating an Excel Table page. If you need to create sample test data in Excel, the RANDBETWEEN function can help you get the job done quickly. This video shows how to use the RANDBETWEEN function to quickly create test data with month headings, customer numbers, and random numbers. You'll also see how change the formulas to static
values. There are written steps on the Excel RAND and RANDBETWEEN Functions page. More Excel Sample Data For Practice Athletes Sample Data Workplace Safety Sample Data Work Orders Sample Data Insurance Policies Sample Data Food Nutrients Sample Data Food Sales Sample Data Hockey Player Sample Data Learn
how to code with beginner-friendly tutorials that make Python approachable (and, dare I say, fun!).




